Resolved
Services renabled
Identified
Ethereum (except consolidation operations) and Near operations have been re-enabled in Kiln Dashboard
Identified
Mantra and Zeta operations have been fully re-enabled in Kiln Dashboard
Identified
With the successful re-enablement of all transaction-crafting endpoints for Ton, Mantra, and Zeta today, Kiln Connect services have now been fully restored.
Identified
All Ethereum endpoints in Kiln Connect have been re-enabled. All ETH staking operations will be re-enabled on Kiln Dashboard tomorrow.
Identified
All staking operations for the following protocols have been re-enabled in Kiln Dashboard: Cosmos, Sei, Celestia, Injective, Fetch, Cronos, Kava, Osmosis and dYdX with enhanced dedicated transaction decoding tools.
Identified
Update Sept 29th - Kiln Connect & Dashboard re-enablement
Today - the following have been re-enabled in mainnet:
✅ All tx-crafting endpoints of Celestia, Injective, Osmosis, Fetch, Sei, Cronos, dYdX, Kava, Cardano, Tron, Polkadot, Kusama, Sui, Tezos, Polygon, Babylon, MultiverseX
This week - the following will be re-enabled:
Oct 1st: All Dashboard operations of Cosmos, Osmosis, Celestia, Injective, Fetch, dYdX, Mantra, Near, DeFi
Before the end of the week: Ethereum
All tx-crafting endpoints of Ethereum, Ton, Mantra, Zeta
All Dashboard operations of Ethereum
Identified
Kiln Widget has now been successfully enabled across all partner UIs.
DeFi and Pooled staking is functional and dedicated staking 32ETH is still paused.
All partner interfaces have been updated with a banner message for user to read about the incident and contact Kiln support for questions.
No further action is required from partners.
Thank you for your patience and support.
Identified
Today - the following services have been re-enabled:
✅ Kiln Dashboard - all Solana crafting flows with an enhanced decoding tool and additional safeguards to ensure users have decoded transactions.
✅ All Cosmos tx-crafting endpoints in mainnet
Next week the following will be re-enabled:
Monday Sept 29th:
All tx-crafting endpoints - Celestia, Injective, Osmosis, Fetch, Mantra, Cronos, dYdX, Kava, Zeta
Week of Sept 29th:
All tx-crafting endpoints & Dashboard crafting operations - Ethereum
Dashboard crafting operations: DeFi, Near, Cosmos, Celestia, Injective, Osmosis, Fetch, Mantra, and dYdX.
The complete timeline for Kiln Connect & Dashboard services re-enablement is available here and is updated regularly.
Our Sales Engineers and Support Engineers are available to assist you where needed - please continue to reach out with feedback and questions as we prioritise enablement. We sincerely apologise for the inconvenience this has caused to your services.
Identified
Application reactivation update:
Widget access is still paused and we plan a reactivation in partners UIs early next week.
For more details, please refer to our FAQ. If you have any further questions or concerns, please don’t hesitate to reach out to us at support@kiln.fi — we’re here to help.
Identified
Today - the following services have been re-enabled:
All Solana and DeFi Kiln Connect tx-crafting endpoints in testnet
TON withdraw request (Single nominator pool) tx-crafting endpoints in mainnet
Tomorrow - the following will be re-enabled:
All Solana and DeFi Kiln Connect tx-crafting endpoints in mainnet
Kiln Dashboard - all Solana crafting flows with an enhanced decoding tool and additional safeguards to ensure users have decoded transactions.
/prepare & /broadcast: Near, Ton, Tron, Cosmos, Celestia, Injective, Osmosis, Fetch, Mantra, Cronos, dYdX, Kava, Zeta
Note for Fireblocks customers who stake SOL with Kiln: Since Friday, all Kiln staked SOL positions have been imported into the Fireblocks console. Therefore, if you wish to stake / unstake your SOL with Kiln validators, using the Fireblocks console (and APIs) instead of Kiln's services, these are available to use now.
Additionally, we confirm that all tx-crafting endpoints for ATOM and NEAR will be available between September 24-29th.The timeline for other service re-enablement is available here and continues to be updated.
Please note that for ETH, services will resume during week of 29th Sept - all endpoints and flows will be available (except OCV1).Our Sales Engineers and Support Engineers are available to assist you where needed - please continue to reach out with feedback and questions as we prioritise enablement. We sincerely apologise for the inconvenience this has caused to your services.
Identified
For resumption of Kiln Connect API endpoints and Dashboard, here’s a detailed timetable for service restoration as part of our Incident FAQs. New information on top of what was shared on Monday (15th):
For ETH, staking on new validators will be available on Monday September 29th. These services will be accessible through our existing API and Dashboard interface.
Each protocol in Kiln Dashboard will be re-enabled with enhanced transaction decoding tools. Note that as the customer and ultimate owner of your assets, it is your sole responsibility to review, check, and verify all transactions before signing and broadcasting them.
Fireblocks are progressing on the import of Kiln positions - starting with Solana - in the Fireblocks console, estimated next week. They will then proceed with Cosmos chains (ATOM, INJ, TIA, DYDX, OSMO) with no ETA yet. Please get in touch with your Fireblocks account manager for the latest on this.
A more detailed timeline for remaining services will be provided soon here, StatusPage and comms.
As a reminder, for several of the top protocols, we now provide the option of an Open-source (MIT) TypeScript code repository which you may use to craft transactions independently, within your own environment, here: https://github.com/kilnfi/tx-crafting-scripts.
We sincerely apologise for all the inconvenience to your services. Our Sales Engineers and Support Engineers are available to advise where helpful. As we work through this incident, please continue to reach out and let us know the highest priority services for you - thank you for all your engagement and patience so far.
Identified
Thank you for your continued patience, as we work through the incident first communicated last week.
For the re-enablement of Kiln’s APIs and Dashboard, below are updates so far:
Kiln Connect /broadcast, /defi, and /solana routes are expected to be made available again September 22-24
Kiln Dashboard will be made available again September 22-24 starting with the Solana protocol, with more robust transaction decoding tools
Fireblocks is expected to have all Kiln Solana stakes imported into its console by end of this week
Fireblocks will also support Cosmos chains in their console soon (ATOM, INJ, TIA, DYDX, OSMO), with no ETA yet. Please contact your Fireblocks account manager for more details
An ETA for the re-enablement of other Kiln Connect API endpoints & other protocols in Kiln Dashboard will follow later this week
For several of the top protocols, we now provide the option of an Open-source (MIT) TypeScript code repository which you may use to craft transactions independently, within your own environment, here: https://github.com/kilnfi/tx-crafting-scripts.
We sincerely apologise again for all the inconvenience to your services. Our Sales Engineers and Support Engineers are available to advise where helpful. Please reach out to us on the usual channels.
Identified
Following our last update, our team is working to provide resumed API and Dashboard services, in order of the highest priority based on assessments of need from our customers. Prioritising security above all, we aim to provide an ETA from early next week, for the first protocol staking operations to be re-enabled.
We greatly appreciate and value your patience. Please continue to contact us today, and over the weekend as required, over slack, telegram and usual channels.
Identified
After thorough reviews by our team and partners, Kiln's Reporting API is now available as before, meaning customers can now conduct GET calls to reporting endpoints for 23 protocols, to see staking and DeFi positions.
We hope to have updates soon on the availability of other paused services. Please continue to watch here, or reach out to us on Slack, TG or your usual way.
Identified
We are continuing our work on restoring services to Kiln Dashboard, dApps, Widget and APIs. We expect to be able to resume some services by end of week and will provide a more precise ETA as soon as possible.
Note: please be cautious of scams: only rely on information from official Kiln channels. We will never ask you to share private keys or transfer funds. As all Kiln interfaces are temporarily paused, any Kiln-branded interface appearing at this time should be considered fraudulent.
Please reach out to support@kiln.fi for any further questions, or via your usual channels.
Identified
The Kiln team and several third-parties have identified the root cause of this incident. We're currently working on restoring services to Kiln Dashboard, Widget and APIs, with no precise ETA yet.
Note: please be cautious of scams: only rely on information from official Kiln channels. We will never ask you to share private keys or transfer funds. As all Kiln interfaces are temporarily paused, any Kiln-branded interface appearing at this time should be considered fraudulent.
Please reach out to support@kiln.fi for any further questions, or via your usual channels.
Investigating
The Kiln team and several third-parties are continuing to thoroughly investigate this incident. We will continue to share any relevant information for customers here once we have it. For the time being, Kiln Dashboard, Widget and APIs continue to remain paused as a precaution. Please reach out on slack, TG or via your local rep for further questions.
Investigating
We are continuing to investigate an incident related to our transaction crafting API. Out of precaution, we are keeping our API and dashboard services paused. We are confident the cause of this incident is not the widely reported npm security incident. Validators and DeFi vaults continue to operate as normal and generate rewards. Thank you for your patience.
Investigating
Dear all,
We are currently investigating a potential issue related to transaction crafting on Kiln Dashboard and APIs. As a temporary precaution, we have paused all staking operations, and will revert once this is remediated. Huge apologies for the inconvenience caused by this.
Validator operations are not affected, and active stakes will continue earning rewards as normal during this time.
Please monitor this StatusPage where this incident is being regularly tracked and updated, or reach out to us on Slack, TG or your usual channel.
We will notify you when staking operations are unpaused.
Investigating
We have temporarily disabled transaction crafting routes for all protocols as a precautionary security measure
Investigating
We have temporarily disabled Solana transaction crafting routes as a precautionary security measure. Our team is actively investigating and will re-enable the service once it is confirmed safe. No other chains are affected.