Monitoring
The data is now caught up following a temporary fix, and we are monitoring.
Identified
Due to a security upgrade of the Cosmos stack by the foundation, Kiln Connect data is currently experiencing a delay due to RPC nodes being out ot sync. This is purely a data issue, staking positions are yielding as expected.
We are working on resolving this and expect to have it solved tomorrow. Thank you for your patience.