Resolved
All data for /rewards is now correct.
Monitoring
We have deployed a fix, the data should now reflect the correct amounts. We are monitoring.
Investigating
We have identified an issue for XTZ on /rewards where amounts are incorrect in some case, we are investigating.