Kiln Responds to Infrastructure Issue With All Ethereum Validators Exit, Funds Remain Protected
Monitoring·Full outage

The Ethereum network has now processed the exit initiation of all Kiln Ethereum validators. The validators are now exiting: this process is expected to take between 10 and 42 days depending on the validator, after which withdrawals will be completed as scheduled by the network which takes up to 9 days. Validators still earn rewards while exiting. These delays are enforced at the protocol level based on how many validators are exiting and cannot be changed by Kiln. To check the exit queue estimate of your validator use BeaconChain (example) see 'Exiting On' date.

Note on Kiln Dedicated & Pooled Staking Smart Contracts

While accessing them is restricted by the incident to Kiln APIs and web applications, the smart contracts are not impacted by this incident. End users continue to generate rewards from their staking position in these smart contracts while validators are exiting.

For Pooled Staking, once the validators are exited, the pool will receive the unstaked ETH and automatically then stake them with new ETH validators. No user actions are expected to be required.

For Dedicated Staking, once the validators are exited, users will be able to withdraw all rewards and their principal as usual. To continue staking, users will be required to stake their principal again.

We have created some end-user FAQs for Dedicated and Pooling users you can refer to here.

Wed, Sep 10, 2025, 05:25 PM
(3 hours ago)
·
Affected components
Updates

Monitoring

The Ethereum network has now processed the exit initiation of all Kiln Ethereum validators. The validators are now exiting: this process is expected to take between 10 and 42 days depending on the validator, after which withdrawals will be completed as scheduled by the network which takes up to 9 days. Validators still earn rewards while exiting. These delays are enforced at the protocol level based on how many validators are exiting and cannot be changed by Kiln. To check the exit queue estimate of your validator use BeaconChain (example) see 'Exiting On' date.

Note on Kiln Dedicated & Pooled Staking Smart Contracts

While accessing them is restricted by the incident to Kiln APIs and web applications, the smart contracts are not impacted by this incident. End users continue to generate rewards from their staking position in these smart contracts while validators are exiting.

For Pooled Staking, once the validators are exited, the pool will receive the unstaked ETH and automatically then stake them with new ETH validators. No user actions are expected to be required.

For Dedicated Staking, once the validators are exited, users will be able to withdraw all rewards and their principal as usual. To continue staking, users will be required to stake their principal again.

We have created some end-user FAQs for Dedicated and Pooling users you can refer to here.

Wed, Sep 10, 2025, 05:25 PM

Investigating

Following our announcement yesterday regarding the Solana incident involving SwissBorg, Kiln is taking additional precautionary measures to safeguard client assets across all the networks. As part of this response, Kiln today began the orderly exit of all of its Ethereum (ETH) validators. The exit process is a precautionary measure designed to ensure the continued integrity of the staked assets.

Please see here for more details and FAQs.

Note: please be cautious of scams: only rely on information from official Kiln channels. We will never ask you to share private keys or transfer funds. As all Kiln interfaces are temporarily paused, any Kiln-branded interface appearing at this time should be considered fraudulent.

Please reach out to support@kiln.fi for any further questions, or via your usual channels.

Wed, Sep 10, 2025, 01:22 AM(16 hours earlier)