[XTZ] Reported delegation and staking rewards are incorrect
Resolved·Degraded performance

The issue is resolved.

Mon, Jun 23, 2025, 08:28 AM
(1 week ago)
·
Affected components
Updates

Resolved

The issue is resolved.

Mon, Jun 23, 2025, 08:28 AM

Monitoring

The fix is deployed and indexing is in progress, we will continue to monitor the situation.

Fri, Jun 13, 2025, 03:23 PM(1 week earlier)

Identified

We identified the issue preventing some staking rewards to be reported correctly. It affects bakers with a huge number of stakers. A fix is currently being tested.

Wed, Jun 11, 2025, 07:20 AM(2 days earlier)

Investigating

Our team noticed both delegation and rewards being reported incorrectly. It seems to affect all addresses and we are actively investigating.

Fri, Jun 6, 2025, 08:10 AM(4 days earlier)