Ethereum Holesky Pectra upgrade
Identified
Ongoing for 3 weeks

The holesky chain is stable again. We are recovering and upgrading our services, some may not be available for now. Should you experience issues testing our products on the Holesky chain, please reach out to our customer support team.

Tue, Mar 18, 2025, 10:15 AM
3d ago
Affected components

No components marked as affected

Updates

Further updates will appear here

Identified

The holesky chain is stable again. We are recovering and upgrading our services, some may not be available for now. Should you experience issues testing our products on the Holesky chain, please reach out to our customer support team.

Tue, Mar 18, 2025, 10:15 AM
3 weeks earlier...

Investigating

Following Pectra hard fork on Ethereum Holesky Testnet. The chain has stopped finalizing. Ethereum staking operations on Kiln Testnet dashboard are disrupted. Our team is working internally and with the community to resolve the issue.

Tue, Feb 25, 2025, 10:02 AM