Ledger Live Staking dApp premptively paused
Resolved
Partial outage
Lasted for 19h

Dear Customers

We are pleased to report that this incident is now resolved. We have determined that no Kiln products were affected by the faulty version of Ledger connect-kit.

All Kiln web applications are now available to use. Thanks for your patience! 

Fri, Dec 15, 2023, 09:16 AM
5 months ago
Affected components
Kiln Dashboard
Updates

Resolved

Dear Customers

We are pleased to report that this incident is now resolved. We have determined that no Kiln products were affected by the faulty version of Ledger connect-kit.

All Kiln web applications are now available to use. Thanks for your patience! 

Fri, Dec 15, 2023, 09:16 AM
15h earlier...

Identified

Following additional investigation we do not believe any of Kiln's products were affected by the faulty version of connect-kit. Out of an abundance of caution we plan to re-enable our web applications at 10:AM CET tomorrow.

Thu, Dec 14, 2023, 05:25 PM
47m earlier...

Identified

Following Ledger's recommendations, we are waiting 24 hours for CDN caches to get rid of the faulty version of connect-kit. We are still investigating the potential impact on Kiln customers.

Thu, Dec 14, 2023, 04:37 PM
1h earlier...

Identified

The Kiln dApps were not using the affected compromised library so there is no expected impact as a result of interacting with Kiln applications. We are re-rebuilding our components with the latest Ledger version of the compromised library stamped by Ledger, qualifying it on our side, before re-opening our dApps.

We expect the incident to be fully resolved in the next couple of hours.

Thu, Dec 14, 2023, 03:21 PM
1h earlier...

Investigating

We are freezing all our frontends due to a Ledger ConnectorKit compromission used in our dapps dependencies (wagmi). Ledger Entreprise, Live and Dashboard dapps are in maintenance mode waiting for a security patch from Ledger team.

Thu, Dec 14, 2023, 01:39 PM
15m earlier...

Investigating

Due to the ongoing Ledger library incident, we are preemptively disabling the Kiln dApp in Ledger Live to protect users. This means the dApp will not load so you will not be able to interact with your Kiln positions using the dApp.

Rest assured that your staking positions are not impacted, this is a UI-level issue.

Please follow https://status.kiln.fi for the latest

Thu, Dec 14, 2023, 01:24 PM