Ledger Live timeout issues on RPC provider
Resolved
Lasted for 15h

Incident is now resolved.

Fri, Aug 11, 2023, 07:28 AM
9 months ago
Affected components

No components marked as affected

Updates

Resolved

Incident is now resolved.

Fri, Aug 11, 2023, 07:28 AM
11h earlier...

Monitoring

The situation has improved, we are still monitoring the situation to gauge the effectiveness of the hotfix in the long run before fully marking this incident as fully resolved.

Thu, Aug 10, 2023, 08:18 PM
3h earlier...

Monitoring

We have deployed a hot-fix to reduce the number of RPC calls and are monitoring the situation.

Thu, Aug 10, 2023, 04:22 PM
11m earlier...

Investigating

A subset of Ledger-Live users report issues when using the Kiln Staking dApp on the reporting side.

This happens for with large wallets, it looks like the RPC provider from Ledger used by the dApp rates limits queries, as a result the dApp doesn't have the necessary data to display the rewards page.

We are trying a fix to reduce the number of RPC calls made by the dApp, which should help.

This does not affect in any way users' stakes and they properly operate.

Thu, Aug 10, 2023, 04:10 PM